るりまサーチ (Ruby 2.6.0)

最速Rubyリファレンスマニュアル検索!
26件ヒット [1-26件を表示] (0.115秒)
トップページ > バージョン:2.6.0[x] > クエリ:Gem::Version[x]

別のキーワード

  1. rubygems gem
  2. rubygems/gem_openssl ssl_available?
  3. rubygems/gem_openssl ensure_ssl_available
  4. gem prefix
  5. gem user_dir

検索結果

Gem::Version (69091.0)

文字列で表現されたバージョンを比較可能 (Comparable) にするためのクラスです。

文字列で表現されたバージョンを比較可能 (Comparable) にするためのクラスです。

バージョンを文字列で表したとき、単純に String#<=> で比較すると、
"1.9" のほうが "1.10" よりも大きい(バージョンが高い)ことになってしまい、
正しく判定できません。
Gem::Version はこの問題を解決します。

//emlist[文字列での比較と Gem::Version での比較][ruby]{
p "1.9" < "1.10" # => false
p Gem::Version.new("1.9") < Gem::Version.new("1.10") # => ...

Gem::Version.create(input) -> Gem::Version | nil (63478.0)

Gem::Version のインスタンスを作成するためのファクトリメソッドです。

Gem::Version のインスタンスを作成するためのファクトリメソッドです。

//emlist[][ruby]{
ver1 = Gem::Version.create('1.3.17') # => #<Gem::Version "1.3.17">
ver2 = Gem::Version.create(ver1) # => #<Gem::Version "1.3.17">
ver3 = Gem::Version.create(nil) # => nil
//}

@param input Gem::Version のインスタンスか文字列を指定します。

@r...

Gem::Version#bump -> Gem::Version (63460.0)

最後の一桁を切り上げた新しい Gem::Version のインスタンスを返します。

最後の一桁を切り上げた新しい Gem::Version のインスタンスを返します。

ただし、英字のプレリリースの部分は、無視されます。

//emlist[][ruby]{
p Gem::Version.new('5.3.1').bump # => #<Gem::Version "5.4">
p Gem::Version.new('5.3.1.a.1').bump # => #<Gem::Version "5.4">
p Gem::Version.new('5.3.1.3.1').bump # => #<Gem::Version "5.3.1.4">
//}

Gem::Version#release -> Gem::Version (63442.0)

self をリリースバージョンにした Gem::Version オブジェクトを返します。

self をリリースバージョンにした Gem::Version オブジェクトを返します。

プレリリースではないバージョンであれば self を返します。

//emlist[例][ruby]{
Gem::Version.new('1.2.0a').release # => #<Gem::Version "1.2.0">
Gem::Version.new('1.2.0').release # => #<Gem::Version "1.2.0">
//}

@see Gem::Version#prerelease?

Gem::Version.new(version) -> Gem::Version (63442.0)

バージョンを表す文字列から、Gem::Version インスタンスを作成します。

バージョンを表す文字列から、Gem::Version インスタンスを作成します。

引数のバージョンを表す文字列とは、 数字かASCII文字の連続であり、ドットで区切られたものです。

//emlist[][ruby]{
p Gem::Version.new('1.2.0a') # => #<Gem::Version "1.2.0a">

# Ruby 2.4.1より、空白文字以外の文字がない場合、バージョンは "0" になります。
p Gem::Version.new(' ') #=> #<Gem::Version "0">
//}

@param version
@raise Argum...

絞り込み条件を変える

Gem::Version#<=>(other) -> -1 | 0 | 1 | nil (63193.0)

self と other を比較して、self が小さい時に -1、 等しい時に 0、大きい時に 1 の整数を返します。 また、other が Gem::Version ではなく比較できないとき、 nil を返します。

self と other を比較して、self が小さい時に -1、
等しい時に 0、大きい時に 1 の整数を返します。
また、other が Gem::Version ではなく比較できないとき、 nil を返します。

//emlist[][ruby]{
p Gem::Version.new("3.9.0") <=> Gem::Version.new("3.10.0") # => -1
p Gem::Version.new("3.0.0") <=> Gem::Version.new("3.0.0") # => 0
p Gem::Version.new("3.0.0") <=> G...

Gem::Version#eql?(other) -> bool (63157.0)

self と other の Gem::Version#version のバージョンが等しいとき true を返します。 そうでなければ false を返します。

self と other の Gem::Version#version のバージョンが等しいとき true を返します。
そうでなければ false を返します。

Comparable を include して作られた == と異なり、"1.0" と "1" は異なるものと判定します。

//emlist[][ruby]{
ver0 = Gem::Version.create('1.0') # #<Gem::Version "1.0">
ver1 = Gem::Version.create('1.0') # #<Gem::Version "1.0">
ver2 = Gem::Ver...

Gem::Version#prerelease? -> bool (63055.0)

self がプレリリースと思われる文字を含むバージョンかどうかを返します。

self がプレリリースと思われる文字を含むバージョンかどうかを返します。

//emlist[例][ruby]{
Gem::Version.new('1.2.0a').prerelease? # => true
Gem::Version.new('1.2.0').prerelease? # => false
//}

@see Gem::Version#release

Gem::Version.correct?(version) -> bool (63055.0)

version が正しいバージョンであれば true を返します。そうでなければ false を返します。

version が正しいバージョンであれば true を返します。そうでなければ false を返します。

//emlist[][ruby]{
p Gem::Version.correct?("9.1") # => true
p Gem::Version.correct?("incorrect") # => false

p Gem::Version.correct?(nil) # => true
# nil versions are discouraged and will be deprecated in Rubygems 4
# version が nil...

Gem::Version#marshal_load(array) -> nil (63037.0)

ダンプされた情報をロードし、自身を破壊的に変更します。

ダンプされた情報をロードし、自身を破壊的に変更します。

//emlist[][ruby]{
version = Gem::Version.new('')
version.marshal_load(["1.2.0a"])
p version # => #<Gem::Version "1.2.0a">
//}

@param array バージョン情報を含む配列を指定します。

絞り込み条件を変える

Gem::Version#marshal_dump -> Array (63019.0)

完全なオブジェクトではなく、バージョン文字列のみダンプします。

完全なオブジェクトではなく、バージョン文字列のみダンプします。

//emlist[][ruby]{
p Gem::Version.new('1.2.0a').marshal_dump # => ["1.2.0a"]
//}

Gem::Version#to_s -> String (63019.0)

バージョン情報を文字列として返します。

バージョン情報を文字列として返します。

//emlist[][ruby]{
version = Gem::Version.new("1.2.3a")
p version.to_s # => "1.2.3a"
p version.version # => "1.2.3a"
//}

Gem::Version#version -> String (63019.0)

バージョン情報を文字列として返します。

バージョン情報を文字列として返します。

//emlist[][ruby]{
version = Gem::Version.new("1.2.3a")
p version.to_s # => "1.2.3a"
p version.version # => "1.2.3a"
//}

Gem::Version::Requirement -> Class (63019.0)

Gem::Requirement のエイリアスです。

Gem::Requirement のエイリアスです。

//emlist[][ruby]{
p Gem::Version::Requirement == Gem::Requirement # => true
//}

Gem::Version::Requirement (9001.0)

Alias of Gem::Requirement

Alias of Gem::Requirement

絞り込み条件を変える

Gem::VersionOption (9001.0)

Gem::Command の --version, --platform オプションのためのモジュールです。

Gem::Command の --version, --platform オプションのためのモジュールです。

Gem::VersionOption#add_platform_option(task = command, *wrap) (9001.0)

option parser に対して --platform オプションを追加します。

option parser に対して --platform オプションを追加します。

@param task コマンド名を指定します。デフォルト値はインクルードされる側のクラスで指定されます。

@param wrap Gem::Command#add_option に渡すその他のオプションを指定します。

Gem::VersionOption#add_version_option(task = command, *wrap) (9001.0)

option parser に対して --version オプションを追加します。

option parser に対して --version オプションを追加します。

@param task コマンド名を指定します。デフォルト値はインクルードされる側のクラスで指定されます。

@param wrap Gem::Command#add_option に渡すその他のオプションを指定します。

Gem::Specification#version -> Gem::Version (304.0)

この Gem パッケージのバージョンを返します。

この Gem パッケージのバージョンを返します。

Gem::Requirement#parse(obj) -> Array (37.0)

バージョンの必要上件をパースして比較演算子とバージョンを要素とする二要素の配列を返します。

バージョンの必要上件をパースして比較演算子とバージョンを要素とする二要素の配列を返します。

@param obj 必要上件を表す文字列または Gem::Version のインスタンスを指定します。

@return 比較演算子と Gem::Version のインスタンスを要素とする二要素の配列を返します。

@raise ArgumentError obj に不正なオブジェクトを指定すると発生します。

絞り込み条件を変える

Kernel#gem(gem_name, *version_requirements) -> bool (37.0)

$LOAD_PATH に Ruby Gem を追加します。

$LOAD_PATH に Ruby Gem を追加します。

指定された Gem をロードする前にその Gem が必要とする Gem をロードします。
バージョン情報を省略した場合は、最も高いバージョンの Gem をロードします。
指定された Gem やその Gem が必要とする Gem が見つからなかった場合は
Gem::LoadError が発生します。

バージョンの指定方法に関しては Gem::Version を参照してください。

rubygems ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前に実行されます。

...

Gem::Requirement#satisfied_by?(version) -> bool (19.0)

引数 version が自身に含まれる全ての必要条件を満たす場合に真を返します。 そうでなければ偽を返します。

引数 version が自身に含まれる全ての必要条件を満たす場合に真を返します。
そうでなければ偽を返します。

@param version Gem::Version のインスタンスを指定します。

@see Gem::Requirement#satisfy?

Gem::Requirement#satisfy?(op, version, required_version) -> bool (19.0)

version op required_version を満たす場合に真を返します。 そうでなければ偽を返します。

version op required_version を満たす場合に真を返します。
そうでなければ偽を返します。

@param op 比較演算子 (<, <=, =, =>, >, !=, ~>) を文字列で指定します。

@param version 外部から与えられるバージョンを Gem::Version のインスタンスで指定します。

@param required_version 満たすべき条件を示すバージョンを指定します。

@see Gem::Requirement#satisfied_by?

Gem::Requirement.create(input) -> Gem::Requirement (19.0)

Gem::Requirement のインスタンスを作成するためのファクトリメソッドです。

Gem::Requirement のインスタンスを作成するためのファクトリメソッドです。

@param input 文字列か配列か Gem::Requirement, Gem::Version のインスタンス
のいずれかを指定します。

@return 上記以外の値を input に指定するとデフォルト値を返します。

@see Gem::Requirement.new, Gem::Requirement.default

Gem::Requirement.new(requirements) -> Gem::Requirement (19.0)

Gem::Requirement のインスタンスを作成します。

Gem::Requirement のインスタンスを作成します。

@param requirements 文字列か配列か Gem::Version のインスタンスを指定します。

@see Gem::Requirement#parse, Gem::Requirement.create

絞り込み条件を変える

Gem::Specification#version=(version) (19.0)

この Gem パッケージのバージョンをセットします。

この Gem パッケージのバージョンをセットします。

@param version バージョンを文字列か Gem::Version のインスタンスで指定します。