るりまサーチ (Ruby 2.6.0)

最速Rubyリファレンスマニュアル検索!
6件ヒット [1-6件を表示] (0.106秒)
トップページ > バージョン:2.6.0[x] > クエリ:Gem::LoadError[x]

別のキーワード

  1. rubygems gem
  2. rubygems/gem_openssl ssl_available?
  3. rubygems/gem_openssl ensure_ssl_available
  4. gem dir
  5. gem sha256

ライブラリ

クラス

モジュール

キーワード

検索結果

Gem::LoadError (69001.0)

Gem をロードできなかった場合に発生するエラーです。

Gem をロードできなかった場合に発生するエラーです。

Gem::LoadError#name -> String (63001.0)

ロードに失敗した Gem の名前を返します。

ロードに失敗した Gem の名前を返します。

Gem::LoadError#name=(gem_name) (63001.0)

ロードに失敗した Gem の名前をセットします。

ロードに失敗した Gem の名前をセットします。

@param gem_name Gem の名前を指定します。

Gem::LoadError#version_requirement -> Get::Requirement (63001.0)

ロードに失敗した Gem の必要条件を返します。

ロードに失敗した Gem の必要条件を返します。

@see Gem::Requirement, Gem::Dependency#version_requirements

Gem::LoadError#version_requirement=(version_requirement) (63001.0)

ロードに失敗した Gem の必要条件をセットします。

ロードに失敗した Gem の必要条件をセットします。

@param version_requirement Gem::Requirement のインスタンスをセットします。

@see Gem::Requirement, Gem::Dependency#version_requirements

絞り込み条件を変える

Kernel#gem(gem_name, *version_requirements) -> bool (37.0)

$LOAD_PATH に Ruby Gem を追加します。

$LOAD_PATH に Ruby Gem を追加します。

指定された Gem をロードする前にその Gem が必要とする Gem をロードします。
バージョン情報を省略した場合は、最も高いバージョンの Gem をロードします。
指定された Gem やその Gem が必要とする Gem が見つからなかった場合は
Gem::LoadError が発生します。

バージョンの指定方法に関しては Gem::Version を参照してください。

rubygems ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前に実行されます。

...