Ruby 2.1.0 リファレンスマニュアル > ライブラリ一覧 > rubygems/installerライブラリ

library rubygems/installer

要約

RubyGems の Gem をインストールするためのライブラリです。

クラス

Gem::Installer

Gem::Installer は Gem を展開し、 Gem に含まれていたファイルをファイルシステム上の正しい位置に配置します。

例外クラス

Gem::Installer::ExtensionBuildError

拡張ライブラリをビルド中にエラーが発生した場合に発生します。

同時にrequireされるライブラリ

rubygems

RubyGems を扱うためのクラスやモジュールが定義されているライブラリです。

rubygems/builder

Gem::Specification のインスタンスから Gem パッケージを作成するためのライブラリです。

rubygems/defaults

RubyGems ライブラリで使用するデフォルト値を返すメソッドを定義したライブラリです。

rubygems/dependency

Gem の依存関係を管理するためのライブラリです。

rubygems/digest/md5

Digest::MD5 をラップするためのライブラリです。

rubygems/digest/sha2

Digest::SHA256 をラップするためのライブラリです。

rubygems/exceptions

RubyGems で使用する例外クラスを定義したライブラリです。

rubygems/ext

拡張ライブラリをビルドするためのライブラリです。

rubygems/ext/builder

拡張ライブラリをビルドするためのクラスを扱うライブラリです。

rubygems/ext/configure_builder

configure スクリプトを元に拡張ライブラリをビルドするクラスを扱うライブラリです。

rubygems/ext/ext_conf_builder

extconf.rb を元にして拡張ライブラリをビルドするためのクラスを扱うライブラリです。

rubygems/ext/rake_builder

Rake を使用して拡張ライブラリをビルドするためのクラスを扱うライブラリです。

rubygems/format

RubyGems の Gem ファイルの内部構造を扱うためのライブラリです。

rubygems/gem_openssl

OpenSSL がインストールされていないシステムがあるかもしれないので、 OpenSSL が使えるかどうかを確認するためのライブラリです。

rubygems/gem_path_searcher

Gem パッケージに含まれているファイルのうちロード可能なものを検索するためのライブラリです。

rubygems/package

このライブラリは Gem パッケージを扱うためのライブラリです。

rubygems/package/f_sync_dir
rubygems/package/tar_header

tar アーカイブの各エントリのヘッダを表すクラスを提供するライブラリです。

rubygems/package/tar_input

gem-format な tar ファイルを読み込む Gem::Package::TarReader のラッパークラスを提供するライブラリです。

rubygems/package/tar_output

gem-format な tar ファイルを書き出す Gem::Package::TarWriter のラッパークラスを提供するライブラリです。

rubygems/package/tar_reader

gem-format な tar ファイルを読むためのクラスを提供するライブラリです。

rubygems/package/tar_reader/entry

tar アーカイブ中のそれぞれのエントリを扱うためのクラスを提供するライブラリです。

rubygems/package/tar_writer

tar ファイルを書き込むためのクラスを提供するライブラリです。

rubygems/platform

選択した Gem のインストールを実行できるプラットフォームのリストを扱うライブラリです。

rubygems/remote_fetcher

リモートソースから Gem パッケージや Gem パッケージの情報を取得するためのライブラリです。

rubygems/requirement

Gem パッケージのバージョンに関する必須条件を扱うためのライブラリです。

rubygems/require_paths_builder

必要であれば、'.require_paths' というファイルを Gem ごとに作成するためのモジュールを提供するためのライブラリです。

rubygems/security

このライブラリは暗号署名を RubyGems パッケージに使用するために使用します。

rubygems/source_index

個々のソースから取得した全ての有効な Gem パッケージをインデックス化するためのライブラリです。

rubygems/source_info_cache

個々の Gem パッケージのインデックス情報のコピーを保存するためのライブラリです。

rubygems/source_info_cache_entry

Gem::SourceInfoCache が持つエントリを表すためのライブラリです。

rubygems/specification

Gem パッケージのメタデータを扱うためのライブラリです。

rubygems/spec_fetcher

リモートリポジトリから Gem のメタデータを取得して更新するためのライブラリです。

rubygems/user_interaction

ユーザとのやりとりを行うライブラリです。

rubygems/version

Gem パッケージのバージョンを扱うためのライブラリです。