るりまサーチ (Ruby 3.1.0)

最速Rubyリファレンスマニュアル検索!
3件ヒット [1-3件を表示] (0.024秒)
トップページ > バージョン:3.1.0[x] > クエリ:OptionParser::InvalidOption[x]

別のキーワード

  1. optionparser on
  2. optionparser getopts
  3. optionparser order
  4. optionparser accept
  5. optionparser summarize

種類

ライブラリ

キーワード

検索結果

OptionParser::InvalidOption (69001.0)

定義されていないオプションが与えられた場合に投げられます。

定義されていないオプションが与えられた場合に投げられます。

optparse (37.0)

コマンドラインのオプションを取り扱うためのライブラリです。

コマンドラインのオプションを取り扱うためのライブラリです。

=== チュートリアル

optparse を使う場合、基本的には

(1) OptionParser オブジェクト opt を生成する。
(2) オプションを取り扱うブロックを opt に登録する。
(3) opt.parse(ARGV) でコマンドラインを実際に parse する。

というような流れになります。

* optiondef
* optionarg
* longoption
* help
* subcmd
* argv
* hyphen_start_file

====[a:optiondef]...

NEWS for Ruby 2.7.0 (19.0)

NEWS for Ruby 2.7.0 このドキュメントは前回リリース以降のバグ修正を除くユーザーに影響のある機能の変更のリストです。

...by/rss/blob/master/NEWS.md

* RubyGems
* RubyGems 3.1.2に更新されました。
* https://github.com/rubygems/rubygems/releases/tag/v3.1.0
* https://github.com/rubygems/rubygems/releases/tag/v3.1.1
* https://github.com/rubygems/rubygems/releases/tag/v3.1.2

* StringScann...