るりまサーチ (Ruby 2.2.0)

最速Rubyリファレンスマニュアル検索!
9件ヒット [1-9件を表示] (0.027秒)
トップページ > バージョン:2.2.0[x] > クエリ:IO[x] > クエリ:requirements[x]

別のキーワード

  1. io popen
  2. io pipe
  3. io readlines
  4. io lines
  5. io each_line

検索結果

Gem::Specification#requirements -> Array (63304.0)

この Gem パッケージを動作させるのに必要な条件を返します。 これはユーザのためのシンプルな情報です。

この Gem パッケージを動作させるのに必要な条件を返します。
これはユーザのためのシンプルな情報です。

Gem::Dependency#version_requirements=(version_requirements) (37225.0)

依存しているバージョンを設定します。

依存しているバージョンを設定します。

@param version_requirements Gem::Requirement のインスタンスを指定します。

Gem::Dependency#version_requirements -> Gem::Requirement (36604.0)

依存しているバージョンを返します。

依存しているバージョンを返します。

Gem::Specification#requirements=(informations) (27604.0)

この Gem パッケージを動作させるのに必要な条件をセットします。 これはユーザのためのシンプルな情報をセットします。

この Gem パッケージを動作させるのに必要な条件をセットします。
これはユーザのためのシンプルな情報をセットします。

@param informations 情報を文字列の配列で指定します。

Gem::LoadError#version_requirement=(version_requirement) (18619.0)

ロードに失敗した Gem の必要条件をセットします。

ロードに失敗した Gem の必要条件をセットします。

@param version_requirement Gem::Requirement のインスタンスをセットします。

@see Gem::Requirement, Gem::Dependency#version_requirements

絞り込み条件を変える

Gem::LoadError#version_requirement -> Get::Requirement (18319.0)

ロードに失敗した Gem の必要条件を返します。

ロードに失敗した Gem の必要条件を返します。

@see Gem::Requirement, Gem::Dependency#version_requirements

Gem::Specification#add_development_dependency(gem, *requirements) -> Array (9325.0)

@todo

@todo

この Gem を実行するための依存関係を追加します。

例:
spec.add_runtime_dependency('jabber4r', '> 0.1', '<= 0.5')


@param gem 依存する Gem の名前か Gem::Dependency のインスタンスを指定します。

@param requirements バージョンの必須条件を指定します。デフォルトは ">= 0" です。

@see Gem::Dependency

Gem::Specification#add_runtime_dependency(gem, *requirements) -> Array (9325.0)

@todo

@todo

この Gem を実行するための依存関係を追加します。

例:
spec.add_runtime_dependency('jabber4r', '> 0.1', '<= 0.5')


@param gem 依存する Gem の名前か Gem::Dependency のインスタンスを指定します。

@param requirements バージョンの必須条件を指定します。デフォルトは ">= 0" です。

@see Gem::Dependency

Kernel#gem(gem_name, *version_requirements) -> bool (622.0)

$LOAD_PATH に Ruby Gem を追加します。

$LOAD_PATH に Ruby Gem を追加します。

指定された Gem をロードする前にその Gem が必要とする Gem をロードします。
バージョン情報を省略した場合は、最も高いバージョンの Gem をロードします。
指定された Gem やその Gem が必要とする Gem が見つからなかった場合は
Gem::LoadError が発生します。

バージョンの指定方法に関しては Gem::Version を参照してください。

rubygems ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前に実行されます。

...