るりまサーチ (Ruby 2.2.0)

最速Rubyリファレンスマニュアル検索!
3件ヒット [1-3件を表示] (0.329秒)

別のキーワード

  1. _builtin new
  2. _builtin inspect
  3. _builtin []
  4. _builtin to_s
  5. _builtin each

ライブラリ

クラス

キーワード

検索結果

Gem::Specification#add_runtime_dependency(gem, *requirements) -> [Gem::Dependency] (45325.0)

この gem の RUNTIME 依存性を追加します。 実行時に必要となる gem を指定します。

この gem の RUNTIME 依存性を追加します。
実行時に必要となる gem を指定します。

//emlist[][ruby]{
# https://github.com/rurema/bitclust/blob/v1.2.3/bitclust-core.gemspec#L25
s.add_runtime_dependency "progressbar", ">= 1.9.0", "< 2.0"
//}

@param gem 依存する gem の名前か Gem::Dependency のインスタンスを指定します。

@param requirements バージョンの必要条件を 0...

Gem::Specification#add_dependency(gem, *requirements) -> [Gem::Dependency] (25.0)

この gem の RUNTIME 依存性を追加します。 実行時に必要となる gem を指定します。

この gem の RUNTIME 依存性を追加します。
実行時に必要となる gem を指定します。

//emlist[][ruby]{
# https://github.com/rurema/bitclust/blob/v1.2.3/bitclust-core.gemspec#L25
s.add_runtime_dependency "progressbar", ">= 1.9.0", "< 2.0"
//}

@param gem 依存する gem の名前か Gem::Dependency のインスタンスを指定します。

@param requirements バージョンの必要条件を 0...

Gem::Specification#add_development_dependency(gem, *requirements) -> [Gem::Dependency] (22.0)

この gem の DEVELOPMENT 依存性を追加します。 この gem の開発時に必要となる gem を指定します。

この gem の DEVELOPMENT 依存性を追加します。
この gem の開発時に必要となる gem を指定します。

//emlist[][ruby]{
gem "rack", "~> 1.6", ">= 1.6.12"
//}

@param gem 依存する gem の名前か Gem::Dependency のインスタンスを指定します。

@param requirements バージョンの必要条件を 0 個以上指定します。デフォルトは ">= 0" です。

@see Gem::Specification#add_runtime_dependency, Gem::Depende...