るりまサーチ

最速Rubyリファレンスマニュアル検索!
144件ヒット [1-100件を表示] (0.059秒)

検索結果

<< 1 2 > >>

Gem::Installer#app_script_text -> String (3.0)

アプリケーションのための実行ファイルの雛形のテキストを返します。

アプリケーションのための実行ファイルの雛形のテキストを返します。

Gem::Installer#bin_dir -> String (3.0)

実行ファイルをインストールするディレクトリを返します。

実行ファイルをインストールするディレクトリを返します。

Gem::Installer#build_extensions (3.0)

拡張ライブラリをビルドします。

拡張ライブラリをビルドします。

拡張ライブラリをビルドするためのファイルタイプとして有効であるのは、
extconf.rb, configure script, Rakefile, mkmf_files です。

Gem::Installer#ensure_dependency(spec, dependency) -> true (3.0)

インストールしようとしている Gem が依存関係を満たしている事を確認します。

...を満たしていない場合は、例外 Gem::InstallError が発生します。

@param spec Gem::Specification のインスタンスを指定します。

@param dependency Gem::Dependency のインスタンスを指定します。

@raise Gem::InstallError 依存関係を満たしていない...

Gem::Installer#extract_files (3.0)

ファイルのインデックスを読み取って、それぞれのファイルを Gem のディレクトリに展開します。

...また、ファイルを Gem ディレクトリにインストールしないようにします。

@raise ArgumentError 自身に Gem::Format がセットされていない場合に発生します。

@raise Gem::InstallError インストール先のパスが不正な場合に発生します。...

絞り込み条件を変える

Gem::Installer#formatted_program_filename(filename) -> String (3.0)

Ruby のコマンドと同じプレフィックスとサフィックスを付けたファイル名を返します。

Ruby のコマンドと同じプレフィックスとサフィックスを付けたファイル名を返します。

@param filename 実行ファイルのファイル名を指定します。

Gem::Installer#gem_home -> String (3.0)

Gem のインストール先を返します。

Gem のインストール先を返します。

Gem::Installer#generate_bin (3.0)

Gem でインストールされる実行ファイルを作成します。

Gem でインストールされる実行ファイルを作成します。

@raise Gem::FilePermissionError インストール先に書込み出来ない場合に発生します。

Gem::Installer#generate_bin_script(filename, bindir) (3.0)

Gem に入っているアプリケーションを実行するためのスクリプトを作成します。

Gem に入っているアプリケーションを実行するためのスクリプトを作成します。

@param filename ファイル名を指定します。

@param bindir 実行ファイルを配置するディレクトリを指定します。

Gem::Installer#generate_bin_symlink(filename, bindir) (3.0)

Gem に入っているアプリケーションを実行するためのシンボリックリンクを作成します。

Gem に入っているアプリケーションを実行するためのシンボリックリンクを作成します。

現在インストールされている Gem よりも新しい Gem をインストールするときは、
シンボリックリンクを更新します。

@param filename ファイル名を指定します。

@param bindir 実行ファイルを配置するディレクトリを指定します。

絞り込み条件を変える

Gem::Installer#generate_windows_script(filename, bindir) (3.0)

コマンドの実行を容易にするために Windows 向けのバッチファイルを作成します。

コマンドの実行を容易にするために Windows 向けのバッチファイルを作成します。

@param bindir 実行ファイルを配置するディレクトリを指定します。

@param filename ファイル名を指定します。

Gem::Installer#install -> Gem::Specification (3.0)

Gem をインストールします。

...返します。

@raise Gem::InstallError 要求された Ruby のバージョンを満たしていない場合に発生します。

@raise Gem::InstallError 要求された RubyGems のバージョンを満たしていない場合に発生します。

@raise Gem::InstallError Zlib::GzipFile::Erro...

Gem::Installer#installation_satisfies_dependency?(dependency) -> bool (3.0)

登録されているソースインデックスが与えられた依存関係を 満たすことができる場合は、真を返します。そうでない場合は偽を返します。

登録されているソースインデックスが与えられた依存関係を
満たすことができる場合は、真を返します。そうでない場合は偽を返します。

@param dependency Gem::Dependency のインスタンスを指定します。
<< 1 2 > >>