るりまサーチ (Ruby 3.1.0)

最速Rubyリファレンスマニュアル検索!
2件ヒット [1-2件を表示] (0.224秒)
トップページ > クエリ:kernel[x] > バージョン:3.1.0[x] > クエリ:rubygems/custom_require[x]

別のキーワード

  1. rexml/document new
  2. rexml/document write
  3. rexml/document to_s
  4. rexml/document clone
  5. rexml/document node_type

ライブラリ

モジュール

検索結果

rubygems/custom_require (114049.0)

Kernel#require を再定義するためのライブラリです。

Kernel#require を再定義するためのライブラリです。

Ruby1.9 以前で使用しています。

Kernel#require(path) -> bool (51067.0)

RubyGems を require すると、Kernel#require が Gem を 要求されたときにロードするように置き換えます。

RubyGems を require すると、Kernel#require が Gem を
要求されたときにロードするように置き換えます。

再定義された Kernel#require を呼び出すと以下の事を行います。
Ruby のロードパスに存在するライブラリを指定した場合はそのままロードします。
そうではなく、インストールされた Gem ファイルの中から見つかった場合は、
その Gem をロードパスに登録します。

@param path ロードしたいライブラリの名前を指定します。

@return 既にロードされているライブラリを再度ロードしようとした場合は false を返します。
...