るりまサーチ (Ruby 3.1.0)

最速Rubyリファレンスマニュアル検索!
4件ヒット [1-4件を表示] (0.024秒)
トップページ > クエリ:kernel[x] > バージョン:3.1.0[x] > ライブラリ:rubygems[x]

別のキーワード

  1. kernel exec
  2. kernel spawn
  3. kernel system
  4. kernel open
  5. kernel gsub

モジュール

キーワード

検索結果

Kernel#require(path) -> bool (27070.0)

RubyGems を require すると、Kernel#require が Gem を 要求されたときにロードするように置き換えます。

...
RubyGems
を require すると、Kernel#require が Gem を
要求されたときにロードするように置き換えます。

再定義された Kernel#require を呼び出すと以下の事を行います。
Ruby のロードパスに存在するライブラリを指定した場合はその...

Kernel#gem(gem_name, *version_requirements) -> bool (27007.0)

$LOAD_PATH に Ruby Gem を追加します。

...った場合は
Gem::LoadError が発生します。

バージョンの指定方法に関しては Gem::Version を参照してください。

rubygems
ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前...

Kernel#time(msg, width = 25) { ... } -> object (27004.0)

与えられたブロックの実行時間を計測して表示します。

与えられたブロックの実行時間を計測して表示します。

@param msg 表示するメッセージを指定します。

@param width 表示する幅を指定します。

@return ブロックの実行結果を返します。

Gem::Commands::LockCommand (52.0)

指定された特定のバージョンの Gem パッケージに依存する Gem を使用するために 必要な Kernel#gem メソッドの呼び出し方法を文字列で出力します。

指定された特定のバージョンの Gem パッケージに依存する Gem を使用するために
必要な Kernel#gem メソッドの呼び出し方法を文字列で出力します。