るりまサーチ (Ruby 2.7.0)

最速Rubyリファレンスマニュアル検索!
270件ヒット [1-100件を表示] (0.269秒)

別のキーワード

  1. shell/builtin-command new
  2. shell/builtin-command each
  3. rubygems/command command
  4. irb/extend-command def_extend_command
  5. irb/extend-command install_extend_commands

ライブラリ

キーワード

検索結果

<< 1 2 3 > >>

Gem::Command#command -> String (63304.0)

コマンドの名前を返します。

コマンドの名前を返します。

DRb::ExtServManager.command -> { String => String|[String] } (54322.0)

サービスを起動するためのコマンドを指定するための Hash を 返します。

サービスを起動するためのコマンドを指定するための Hash を
返します。

Hash のキーがサービス名で、値がそのサービスを起動するためのコマンドです。
この Hash を変更することでサービスを定義します。
DRb::ExtServManager.command= で Hash 自体を
変更することでも同じことができます。

コマンドは文字列、もしくは文字列の配列で指定します。
文字列で指定した場合は Kernel.#spawn で
プロセスを起動する際に shell 経由で起動されます。
文字列の配列で指定すると shell を経由せずに起動されます。

rubygems/commands/generate_index_command (36037.0)

ある Gem サーバに対するインデックスを作成するためのライブラリです。

ある Gem サーバに対するインデックスを作成するためのライブラリです。

Usage: gem generate_index [options]
Options:
-d, --directory=DIRNAME repository base dir containing gems subdir
Common Options:
-h, --help このコマンドのヘルプを表示します
-V, --[no-]verbose 表示を詳細にします
...

rubygems/commands/lock_command (36037.0)

指定された特定のバージョンの Gem パッケージに依存する Gem を使用するために 必要な Kernel#gem メソッドの呼び出し方法を文字列で出力します。

指定された特定のバージョンの Gem パッケージに依存する Gem を使用するために
必要な Kernel#gem メソッドの呼び出し方法を文字列で出力します。

Usage: gem lock GEMNAME-VERSION [GEMNAME-VERSION ...] [options]
Options:
-s, --[no-]strict 依存関係を満たせない場合に失敗します
Common Options:
-h, --help このコマンドのヘルプを表示します
...

rubygems/commands/pristine_command (36037.0)

インストールされている Gem パッケージを初期状態にするためのライブラリです。

インストールされている Gem パッケージを初期状態にするためのライブラリです。

Usage: gem pristine [args] [options]
Options:
--all インストールされている全ての Gem パッケージを
初期状態に戻します
-v, --version VERSION 指定したバージョンの Gem パッケージを
...

絞り込み条件を変える

rubygems/commands/help_command (36019.0)

Gem コマンドに関するヘルプを提供するためのライブラリです。

Gem コマンドに関するヘルプを提供するためのライブラリです。

Usage: gem help ARGUMENT [options]
Common Options:
-h, --help このコマンドのヘルプを表示します
-V, --[no-]verbose 表示を詳細にします
-q, --quiet 静かに実行します
--config-file FILE 指定された設定ファイルを使用します
...

rubygems/commands/server_command (36019.0)

ローカルにインストールされている Gem パッケージとそのドキュメントを HTTP サーバに 載せて公開するためのライブラリです。

ローカルにインストールされている Gem パッケージとそのドキュメントを HTTP サーバに
載せて公開するためのライブラリです。

Usage: gem server [options]
Options:
-p, --port=PORT port to listen on
-d, --dir=GEMDIR directory from which to serve gems
--[no-]daemon run as a daemon
...

rubygems/commands/build_command (36001.0)

Gem パッケージをビルドするためのライブラリです。

Gem パッケージをビルドするためのライブラリです。


Usage: gem build GEMSPEC_FILE [options]
Common Options:
-h, --help このコマンドのヘルプを表示します
-V, --[no-]verbose 表示を詳細にします
-q, --quiet 静かに実行します
--config-file FILE 指定された設定ファイルを使用します...

rubygems/commands/cert_command (36001.0)

Gem パッケージの証明書や署名の設定を管理するためのライブラリです。

Gem パッケージの証明書や署名の設定を管理するためのライブラリです。

Usage: gem cert [options]
Options:
-a, --add CERT 信頼された証明書を追加します
-l, --list 信頼されている証明書の一覧を表示します
-r, --remove STRING STRING を含む証明書を削除します
-b, --build EMAIL_ADDR EMAIL_ADDR ...

rubygems/commands/check_command (36001.0)

インストールされている Gem パッケージを検証するためのライブラリです。

インストールされている Gem パッケージを検証するためのライブラリです。

Usage: gem check [options]
Options:
--verify FILE 内部のチェックサムにより Gem パッケージを検証します
-a, --alien 管理されていないパッケージを報告します
-t, --test Gem パッケージのユニットテストを実行します
-v, --version VERSION ...

絞り込み条件を変える

rubygems/commands/cleanup_command (36001.0)

ローカルにインストールされている古い Gem を削除するライブラリです。

ローカルにインストールされている古い Gem を削除するライブラリです。

Usage: gem cleanup [GEMNAME ...] [options]
Options:
-d, --dryrun
Common Options:
-h, --help このコマンドのヘルプを表示します
-V, --[no-]verbose 表示を詳細にします
-q, --quiet 静かに実行します
--...

rubygems/commands/contents_command (36001.0)

インストールされている Gem パッケージに含まれているファイルリストを表示するためのライブラリです。

インストールされている Gem パッケージに含まれているファイルリストを表示するためのライブラリです。

Usage: gem contents GEMNAME [options]
Options:
-v, --version VERSION 指定されたバージョンの Gem パッケージの内容を表示します
-s, --spec-dir a,b,c 指定されたパス以下にある Gem パッケージを検索します
-l, --[no-]lib-only Gem パッケージの lib ディ...

rubygems/commands/dependency_command (36001.0)

インストールされている Gem パッケージの依存関係を表示するためのライブラリです。

インストールされている Gem パッケージの依存関係を表示するためのライブラリです。

Usage: gem dependency GEMNAME [options]
Options:
-v, --version VERSION 指定したバージョンの依存関係を表示します
--platform PLATFORM 指定したプラットフォームの依存関係を表示します
-R, --[no-]reverse-dependencies この Gem を使用している Gem を表示します
-p, --p...

rubygems/commands/environment_command (36001.0)

RubyGems の環境に関する情報を表示するためのライブラリです。

RubyGems の環境に関する情報を表示するためのライブラリです。

Usage: gem environment [arg] [options]
Common Options:
-h, --help このコマンドのヘルプを表示します
-V, --[no-]verbose 表示を詳細にします
-q, --quiet 静かに実行します
--config-file FILE 指定された設定ファイル...

rubygems/commands/fetch_command (36001.0)

Gem パッケージをダウンロードしてカレントディレクトリに保存するためのライブラリです。

Gem パッケージをダウンロードしてカレントディレクトリに保存するためのライブラリです。

Usage: gem fetch GEMNAME [GEMNAME ...] [options]
Options:
-v, --version VERSION 指定されたバージョンの Gem を取得します
--platform PLATFORM 指定されたプラットフォームの Gem を取得します
Local/Remote Options:
-B, --bulk-threshold COUNT ...

絞り込み条件を変える

rubygems/commands/install_command (36001.0)

Gem パッケージをローカルリポジトリにインストールするためのライブラリです。

Gem パッケージをローカルリポジトリにインストールするためのライブラリです。

Usage: gem install GEMNAME [GEMNAME ...] [options] -- --build-flags [options]
Options:
--platform PLATFORM 指定されたプラットフォームの Gem パッケージをインストールします
-v, --version VERSION 指定されたバージョンの Gem パッケージをインストールします
Install/Update Op...

rubygems/commands/list_command (36001.0)

Gem パッケージの名前を前方一致で検索するためのライブラリです。

Gem パッケージの名前を前方一致で検索するためのライブラリです。

Usage: gem list [STRING] [options]
Options:
-i, --[no-]installed Check for installed gem
-v, --version VERSION 指定されたバージョンの一覧を出力します
-d, --[no-]details Gem パッケージの詳細も表示します
--[no-]versions ...

rubygems/commands/mirror_command (36001.0)

リモートリポジトリをローカルリポジトリにミラーするためのライブラリです。

リモートリポジトリをローカルリポジトリにミラーするためのライブラリです。

Usage: gem mirror [options]
Common Options:
-h, --help このコマンドのヘルプを表示します
-V, --[no-]verbose 表示を詳細にします
-q, --quiet 静かに実行します
--config-file FILE 指定された設定ファイルを使用します
...

rubygems/commands/outdated_command (36001.0)

更新が必要な Gem パッケージの一覧を出力するためのライブラリです。

更新が必要な Gem パッケージの一覧を出力するためのライブラリです。

Usage: gem outdated [options]
Options:
--platform PLATFORM 指定されたプラットフォームに関する情報を表示します
Local/Remote Options:
-l, --local 操作をローカルに限定します
-r, --remote 操作をリモートに限定します
-b, --both ...

rubygems/commands/query_command (36001.0)

Gem パッケージの情報を検索するためのライブラリです。

Gem パッケージの情報を検索するためのライブラリです。

Usage: gem query [options]
Options:
-i, --[no-]installed Check for installed gem
-v, --version VERSION Specify version of gem to query
-n, --name-matches REGEXP 与えられた正規表現にマッチする Gem パッケージを
検...

絞り込み条件を変える

rubygems/commands/rdoc_command (36001.0)

RDoc と ri のライブラリを生成するためのライブラリです。

RDoc と ri のライブラリを生成するためのライブラリです。

Usage: gem rdoc [args] [options]
Options:
--all インストールされている全ての Gem パッケージの
RDoc/RI ドキュメントを生成します。
--[no-]rdoc RDoc を含めます
--[no-]ri RI ...

rubygems/commands/search_command (36001.0)

指定された文字列を含む Gem パッケージを全て表示するためのライブラリです。

指定された文字列を含む Gem パッケージを全て表示するためのライブラリです。

Usage: gem search [STRING] [options]
Options:
-i, --[no-]installed Check for installed gem
-v, --version VERSION Specify version of gem to search
-d, --[no-]details Display detailed information of g...

rubygems/commands/sources_command (36001.0)

Gem パッケージの取得元の情報を管理するためのライブラリです。

Gem パッケージの取得元の情報を管理するためのライブラリです。

Usage: gem sources [options]
Options:
-a, --add SOURCE_URI 取得元を追加します
-l, --list 取得元一覧を表示します
-r, --remove SOURCE_URI 取得元を削除します
-u, --update 取得元のキャッシュを更新します
-c, --clear-...

rubygems/commands/specification_command (36001.0)

指定された Gem パッケージの gemspec の情報を YAML 形式で表示するためのライブラリです。

指定された Gem パッケージの gemspec の情報を YAML 形式で表示するためのライブラリです。

Usage: gem specification [GEMFILE] [options]
Options:
-v, --version VERSION Specify version of gem to examine
--platform PLATFORM Specify the platform of gem to specification
--all ...

rubygems/commands/stale_command (36001.0)

インストールされている Gem パッケージの一覧をアクセス時刻とともに表示するための ライブラリです。

インストールされている Gem パッケージの一覧をアクセス時刻とともに表示するための
ライブラリです。

絞り込み条件を変える

rubygems/commands/uninstall_command (36001.0)

Gem パッケージをアンインストールするためのライブラリです。

Gem パッケージをアンインストールするためのライブラリです。

Usage: gem uninstall GEMNAME [GEMNAME ...] [options]
Options:
-a, --[no-]all Uninstall all matching versions
-I, --[no-]ignore-dependencies Ignore dependency requirements while
uninstalling
-x, --...

rubygems/commands/unpack_command (36001.0)

指定された Gem パッケージをカレントディレクトリに展開するためのライブラリです。

指定された Gem パッケージをカレントディレクトリに展開するためのライブラリです。

Usage: gem unpack GEMNAME [options]
Options:
--target 展開先のディレクトリを指定します
-v, --version VERSION 展開する Gem パッケージのバージョンを指定します
Common Options:
-h, --help このコマンドのヘルプを表示します
-...

rubygems/commands/update_command (36001.0)

ローカルリポジトリにインストールされている Gem パッケージを更新するためのライブラリです。

ローカルリポジトリにインストールされている Gem パッケージを更新するためのライブラリです。

rubygems/commands/which_command (36001.0)

指定された Gem パッケージに含まれるライブラリのパスを見つけるためのライブラリです。

指定された Gem パッケージに含まれるライブラリのパスを見つけるためのライブラリです。

Gem::CommandManager#find_command(command_name) -> Gem::Command | nil (27946.0)

登録されているコマンドからマッチしたものを返します。

登録されているコマンドからマッチしたものを返します。

@param command_name コマンド名を文字列で指定します。

@return Gem::Command のサブクラスのインスタンスを返します。

@raise RuntimeError マッチする可能性のあるコマンドが複数ある場合に発生します。
また、マッチするコマンドが無かった場合にも発生します。

絞り込み条件を変える

Gem::CommandManager#find_command_possibilities(command_name) -> Array (27625.0)

登録されているコマンドでマッチする可能性のあるものを返します。

登録されているコマンドでマッチする可能性のあるものを返します。

@param command_name コマンド名を文字列で指定します。

Gem::CommandManager#register_command(command_name) -> false (27625.0)

コマンドを自身に登録します。

コマンドを自身に登録します。

@param command_name コマンド名をシンボルで指定します。

IRB::ExtendCommandBundle.install_extend_commands -> object (27319.0)

定義済みの拡張を読み込みます。

定義済みの拡張を読み込みます。

irb で以下のメソッドが利用できるようになります。(それぞれ 1 つだけ抜粋)

* irb_current_working_workspace
* irb_change_workspace
* irb_workspaces
* irb_push_workspace
* irb_pop_workspace
* irb_load
* irb_require
* irb_source
* irb
* irb_jobs
* irb_fg
* irb_kill
* irb_help

irb/extend-command が requir...

Gem::CommandManager#command_names -> Array (27304.0)

登録されているコマンド名の配列を返します。

登録されているコマンド名の配列を返します。

IRB::ExtendCommandBundle.def_extend_command(cmd_name, cmd_class, load_file = nil, *aliases) -> object (27304.0)

irb に cmd_name で指定したメソッドが実行できるように拡張します。

irb に cmd_name で指定したメソッドが実行できるように拡張します。

@param cmd_name メソッド名を Symbol か文字列で指定します。
cmd_class で指定するクラスの execute メソッドとして定
義してある必要があります。

@param cmd_class 指定した拡張が定義されたクラス名を Symbol、
String、Class のいずれかで指定します。
なお、このクラスは IRB::ExtendCommand ...

絞り込み条件を変える

Gem::Commands::BuildCommand (27001.0)

Gem パッケージをビルドするためのクラスです。

Gem パッケージをビルドするためのクラスです。

Gem::Commands::CertCommand (27001.0)

Gem パッケージの証明書や書名の設定を管理するためのクラスです。

Gem パッケージの証明書や書名の設定を管理するためのクラスです。

Gem::Commands::CheckCommand (27001.0)

インストールされている Gem パッケージを検証するためのクラスです。

インストールされている Gem パッケージを検証するためのクラスです。

Gem::Commands::CleanupCommand (27001.0)

ローカルにインストールされている古い Gem を削除するクラスです。

ローカルにインストールされている古い Gem を削除するクラスです。

Gem::Commands::ContentsCommand (27001.0)

インストールされている Gem パッケージに含まれているファイルリストを表示するためのクラスです。

インストールされている Gem パッケージに含まれているファイルリストを表示するためのクラスです。

絞り込み条件を変える

Gem::Commands::DependencyCommand (27001.0)

インストールされている Gem パッケージの依存関係を表示するためのクラスです。

インストールされている Gem パッケージの依存関係を表示するためのクラスです。

Gem::Commands::EnvironmentCommand (27001.0)

RubyGems の環境に関する情報を表示するためのクラスです。

RubyGems の環境に関する情報を表示するためのクラスです。

Gem::Commands::FetchCommand (27001.0)

Gem パッケージをダウンロードしてカレントディレクトリに保存するためのクラスです。

Gem パッケージをダウンロードしてカレントディレクトリに保存するためのクラスです。

Gem::Commands::GenerateIndexCommand (27001.0)

ある Gem サーバに対するインデックスを作成するためのクラスです。

ある Gem サーバに対するインデックスを作成するためのクラスです。

Gem::Commands::HelpCommand (27001.0)

Gem コマンドに関するヘルプを提供するためのクラスです。

Gem コマンドに関するヘルプを提供するためのクラスです。

絞り込み条件を変える

Gem::Commands::InstallCommand (27001.0)

Gem パッケージをローカルリポジトリにインストールするためのクラスです。

Gem パッケージをローカルリポジトリにインストールするためのクラスです。

Gem::Commands::ListCommand (27001.0)

Gem パッケージの名前を前方一致で検索するためのクラスです。

Gem パッケージの名前を前方一致で検索するためのクラスです。

Gem::Commands::LockCommand (27001.0)

指定された特定のバージョンの Gem パッケージに依存する Gem を使用するために 必要な Kernel#gem メソッドの呼び出し方法を文字列で出力します。

指定された特定のバージョンの Gem パッケージに依存する Gem を使用するために
必要な Kernel#gem メソッドの呼び出し方法を文字列で出力します。

Gem::Commands::MirrorCommand (27001.0)

リモートリポジトリをローカルリポジトリにミラーするためのクラスです。

リモートリポジトリをローカルリポジトリにミラーするためのクラスです。

Gem::Commands::OutdatedCommand (27001.0)

更新が必要な Gem パッケージの一覧を出力するためのクラスです。

更新が必要な Gem パッケージの一覧を出力するためのクラスです。

絞り込み条件を変える

Gem::Commands::PristineCommand (27001.0)

インストールされている Gem パッケージを初期状態にするためのクラスです。

インストールされている Gem パッケージを初期状態にするためのクラスです。

Gem::Commands::QueryCommand (27001.0)

Gem パッケージの情報を検索するためのクラスです。

Gem パッケージの情報を検索するためのクラスです。

Gem::Commands::RdocCommand (27001.0)

RDoc と ri のライブラリを生成するためのクラスです。

RDoc と ri のライブラリを生成するためのクラスです。

Gem::Commands::SearchCommand (27001.0)

指定された文字列を含む Gem パッケージを全て表示するためのクラスです。

指定された文字列を含む Gem パッケージを全て表示するためのクラスです。

Gem::Commands::ServerCommand (27001.0)

ローカルにインストールされている Gem パッケージとそのドキュメントを HTTP サーバに 載せて公開するためのクラスです。

ローカルにインストールされている Gem パッケージとそのドキュメントを HTTP サーバに
載せて公開するためのクラスです。

絞り込み条件を変える

Gem::Commands::SourcesCommand (27001.0)

Gem パッケージの取得元の情報を管理するためのクラスです。

Gem パッケージの取得元の情報を管理するためのクラスです。

Gem::Commands::SpecificationCommand (27001.0)

指定された Gem パッケージの gemspec の情報を YAML 形式で表示するためのクラスです。

指定された Gem パッケージの gemspec の情報を YAML 形式で表示するためのクラスです。

Gem::Commands::StaleCommand (27001.0)

インストールされている Gem パッケージの一覧をアクセス時刻とともに表示するための クラスです。

インストールされている Gem パッケージの一覧をアクセス時刻とともに表示するための
クラスです。

Gem::Commands::UninstallCommand (27001.0)

Gem パッケージをアンインストールするためのクラスです。

Gem パッケージをアンインストールするためのクラスです。

Gem::Commands::UnpackCommand (27001.0)

指定された Gem パッケージをカレントディレクトリに展開するためのクラスです。

指定された Gem パッケージをカレントディレクトリに展開するためのクラスです。

絞り込み条件を変える

Gem::Commands::UpdateCommand (27001.0)

ローカルリポジトリにインストールされている Gem パッケージを更新するためのクラスです。

ローカルリポジトリにインストールされている Gem パッケージを更新するためのクラスです。

Gem::Commands::WhichCommand (27001.0)

指定された Gem パッケージに含まれるライブラリのパスを見つけるためのクラスです。

指定された Gem パッケージに含まれるライブラリのパスを見つけるためのクラスです。

Usage: gem which FILE [...] [options]
Options:
-a, --[no-]all show all matching files
-g, --[no-]gems-first search gems before non-gems
Common Options:
-h, --help このコマンドのヘルプを表示し...

IRB::ExtendCommand::IrbCommand (27001.0)

irb 中の irb コマンドのための拡張を定義したクラスです。

irb 中の irb コマンドのための拡張を定義したクラスです。

Rake::PackageTask#tar_command=(command) (18625.0)

tar コマンドとして使用するコマンドを設定します。

tar コマンドとして使用するコマンドを設定します。

@param command コマンドを文字列で指定します。

Rake::PackageTask#zip_command=(command) (18625.0)

zip コマンドとして使用するコマンドを設定します。

zip コマンドとして使用するコマンドを設定します。

@param command コマンドを文字列で指定します。

絞り込み条件を変える

IRB::ContextExtender.install_extend_commands -> object (18337.0)

定義済みの拡張を読み込みます。

定義済みの拡張を読み込みます。

IRB::Context で以下のメソッドが利用できるようになります。

* eval_history=
* use_tracer=
* math_mode=
* use_loader=
* save_history=

irb/extend-command が require された時にライブラリ内部で自動的
に実行されます。

@see IRB::ContextExtender.def_extend_command

DRb::ExtServManager.command=(cmd) (18322.0)

サービスを起動するためのコマンドを指定するための Hash を 設定します。

サービスを起動するためのコマンドを指定するための Hash を
設定します。

@param cmd コマンドを設定した Hash
@see DRb::ExtServManager.command

IRB::ContextExtender.def_extend_command(cmd_name, load_file, *aliases) -> object (18304.0)

IRB::Context に cmd_name で指定したメソッドが実行できるように拡張 します。

IRB::Context に cmd_name で指定したメソッドが実行できるように拡張
します。

@param cmd_name メソッド名を Symbol で指定します。
IRB::Context クラスのインスタンスメソッドとして定
義してある必要があります。

@param load_file cmd_name で指定したメソッドが定義されたファイル名を指
定します。このファイルは自動的に require されます。

@param aliases cmd_name の別名を Symb...

Kernel#cc_command(opt = "") -> String (18304.0)

実際にコンパイルする際に使用するコマンドを返します。

実際にコンパイルする際に使用するコマンドを返します。

@param opt コンパイラに与える追加のコマンドライン引数を指定します。

@see RbConfig.expand

Kernel#cpp_command(outfile, opt = "") -> String (18304.0)

実際にプリプロセッサを実行する際に使用するコマンドを返します。

実際にプリプロセッサを実行する際に使用するコマンドを返します。

@param outfile 出力ファイルの名前を指定します。

@param opt プリプロセッサに与える追加のコマンドライン引数を指定します。

@see RbConfig.expand

絞り込み条件を変える

Kernel#link_command(ldflags, opt = "", libpath = $DEFLIBPATH|$LIBPATH) -> String (18304.0)

実際にリンクする際に使用するコマンドを返します。

実際にリンクする際に使用するコマンドを返します。

@param ldflags LDFLAGS に追加する値を指定します。

@param opt LIBS に追加する値を指定します。

@param libpath LIBPATH に指定する値を指定します。

@see RbConfig.expand

Rake::PackageTask#tar_command -> String (18304.0)

tar コマンドとして使用するコマンドを返します。

tar コマンドとして使用するコマンドを返します。

デフォルトは 'tar' です。

Rake::PackageTask#zip_command -> String (18304.0)

zip コマンドとして使用するコマンドを返します。

zip コマンドとして使用するコマンドを返します。

デフォルトは 'zip' です。

FileUtils.commands -> Array (18301.0)

何らかのオプションを持つメソッド名の配列を返します。

何らかのオプションを持つメソッド名の配列を返します。

require 'fileutils'
FileUtils.commands # => ["chmod", "cp", "cp_r", "install", ...]

rubygems/command_manager (18091.0)

gem コマンドによってサポートされているサブコマンドを管理するライブラリです。

gem コマンドによってサポートされているサブコマンドを管理するライブラリです。

Extra commands can be provided by writing a rubygems_plugin.rb
file in an installed gem. You should register your command against the
Gem::CommandManager instance, like this:

# file rubygems_plugin.rb
require 'rubygems/command_manager'

class Gem::Co...

絞り込み条件を変える

Gem::Command (18001.0)

全ての gem コマンドのスーパークラスです。

全ての gem コマンドのスーパークラスです。

Gem::CommandLineError (18001.0)

コマンドラインの例外です。

コマンドラインの例外です。

Gem::CommandManager (18001.0)

gem コマンドによってサポートされているサブコマンドを管理するクラスです。

gem コマンドによってサポートされているサブコマンドを管理するクラスです。

Gem::Commands::BuildCommand#arguments -> String (18001.0)

引数の説明を表す文字列を返します。

引数の説明を表す文字列を返します。

Gem::Commands::BuildCommand#execute -> () (18001.0)

コマンドを実行します。

コマンドを実行します。

絞り込み条件を変える

Gem::Commands::BuildCommand#load_gemspecs(filename) -> Array (18001.0)

gemspec ファイルをロードします。

gemspec ファイルをロードします。

@param filename ファイル名を指定します。

Gem::Commands::BuildCommand#usage -> String (18001.0)

使用方法を表す文字列を返します。

使用方法を表す文字列を返します。

Gem::Commands::BuildCommand#yaml?(filename) -> bool (18001.0)

与えられたファイル名を持つファイルが yaml ファイルである場合に真を返します。

与えられたファイル名を持つファイルが yaml ファイルである場合に真を返します。

@param filename ファイル名を指定します。

Gem::Commands::DependencyCommand#arguments -> String (18001.0)

引数の説明を表す文字列を返します。

引数の説明を表す文字列を返します。

Gem::Commands::DependencyCommand#execute -> () (18001.0)

コマンドを実行します。

コマンドを実行します。

絞り込み条件を変える

Gem::Commands::DependencyCommand#find_gems(name, source_index) -> Hash (18001.0)

与えられた Gem の名前をインデックスから検索します。

与えられた Gem の名前をインデックスから検索します。

@param name Gem の名前を指定します。

@param source_index Gem::SourceIndex のインスタンスを指定します。

@see Gem::SourceIndex#search

Gem::Commands::DependencyCommand#find_reverse_dependencies(spec) -> Array (18001.0)

与えられた Gem スペックに依存する Gem のリストを返します。

与えられた Gem スペックに依存する Gem のリストを返します。

@param spec Gem::Specification のインスタンスを指定します。

Gem::Commands::DependencyCommand#print_dependencies(spec, level = 0) -> String (18001.0)

依存関係を表す文字列を返します。

依存関係を表す文字列を返します。

@param spec Gem::Specification のインスタンスを指定します。

@param level 依存関係の深さを指定します。

Gem::Commands::DependencyCommand#usage -> String (18001.0)

使用方法を表す文字列を返します。

使用方法を表す文字列を返します。

Gem::Commands::HelpCommand::EXAMPLES -> String (18001.0)

使用例を表す文字列です。

使用例を表す文字列です。

絞り込み条件を変える

Gem::Commands::HelpCommand::PLATFORMS -> String (18001.0)

プラットフォームに関する記述を格納している文字列です。

プラットフォームに関する記述を格納している文字列です。

Gem::Commands::LockCommand#complain(message) -> () (18001.0)

指定されたメッセージを表示します。--strict が有効な場合は例外が発生します。

指定されたメッセージを表示します。--strict が有効な場合は例外が発生します。

@param message 表示するメッセージを指定します。

@raise Gem::Exception コマンドラインオプションに --strict が指定されている場合に発生します。

Gem::Commands::LockCommand#spec_path(gem_full_name) -> String (18001.0)

指定された Gem パッケージの gemspec ファイルのフルパスを返します。

指定された Gem パッケージの gemspec ファイルのフルパスを返します。

@param gem_full_name Gem パッケージの名前を指定します。

Gem::Commands::UnpackCommand#get_path(gemname, version_req) -> String | nil (18001.0)

引数で指定された条件にマッチする Gem パッケージを保存しているパスを返します。

引数で指定された条件にマッチする Gem パッケージを保存しているパスを返します。

@param gemname Gem パッケージの名前を指定します。

@param version_req バージョンの満たすべき条件を文字列で指定します。

Gem::Commands::UpdateCommand#do_rubygems_update(version) (18001.0)

RubyGems 自体を更新します。

RubyGems 自体を更新します。

絞り込み条件を変える

Gem::Commands::UpdateCommand#which_to_update(highest_installed_gems, gem_names) -> Array (18001.0)

更新が必要な Gem のリストを返します。

更新が必要な Gem のリストを返します。

Gem::Commands::WhichCommand#find_paths(package_name, dirs) -> Array (18001.0)

dirs から package_name という名前を持つファイルを探索します。

dirs から package_name という名前を持つファイルを探索します。

以下の拡張子を持つファイルが対象です。

%w[.rb .rbw .so .dll .bundle]

@param package_name ファイルの名前を指定します。

@param dirs 探索するディレクトリを文字列の配列で指定します。

Gem::Commands::WhichCommand#gem_paths(spec) -> Array (18001.0)

与えられた Gem::Specification のインスタンスからその Gem が require するファイルのあるディレクトリをまとめて返します。

与えられた Gem::Specification のインスタンスからその Gem が
require するファイルのあるディレクトリをまとめて返します。

@param spec Gem::Specification のインスタンスを指定します。

Gem::Commands::WhichCommand::EXT -> [String] (18001.0)

拡張子を表す配列です。

拡張子を表す配列です。

%w[.rb .rbw .so .dll .bundle]

IRB::ExtendCommand::IrbCommand#execute(*obj) -> IRB::Irb (18001.0)

新しいサブ irb インタプリタを起動します。

新しいサブ irb インタプリタを起動します。

@param obj 新しいサブ irb インタプリタで self にするオブジェクトを指定
します。省略した場合は irb を起動したときの main オブジェク
トを self にします。

絞り込み条件を変える

<< 1 2 3 > >>