るりまサーチ (Ruby 2.6.0)

最速Rubyリファレンスマニュアル検索!
2件ヒット [1-2件を表示] (0.322秒)

別のキーワード

  1. rubygems/user_interaction new
  2. rubygems/package/tar_writer new
  3. rubygems/user_interaction done
  4. rubygems/user_interaction count
  5. rubygems/user_interaction updated

検索結果

Kernel#gem(gem_name, *version_requirements) -> bool (79186.0)

$LOAD_PATH に Ruby Gem を追加します。

...った場合は
Gem::LoadError が発生します。

バージョンの指定方法に関しては Gem::Version を参照してください。

rubygems
ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前...

Kernel#require(path) -> bool (139.0)

RubyGems を require すると、Kernel#require が Gem を 要求されたときにロードするように置き換えます。

...
RubyGems
を require すると、Kernel#require が Gem を
要求されたときにロードするように置き換えます。

再定義された Kernel#require を呼び出すと以下の事を行います。
Ruby のロードパスに存在するライブラリを指定した場合はその...