るりまサーチ (Ruby 2.4.0)

最速Rubyリファレンスマニュアル検索!
1件ヒット [1-1件を表示] (0.094秒)
トップページ > モジュール:Kernel[x] > クエリ:Kernel.#require[x] > クエリ:$OFS[x] > バージョン:2.4.0[x] > クエリ:$FIELD_SEPARATOR[x] > ライブラリ:rubygems/custom_require[x]

別のキーワード

  1. kernel require
  2. getoptlong require_order
  3. kernel $program_name
  4. irb/ext/use-loader irb_require
  5. rubygems/custom_require require

検索結果

Kernel#require(path) -> bool (117493.0)

RubyGems を require すると、Kernel#require が Gem を 要求されたときにロードするように置き換えます。

...RubyGems を require すると、Kernel#require が Gem を
要求されたときにロードするように置き換えます。

再定義された Kernel#require を呼び出すと以下の事を行います。
Ruby のロードパスに存在するライブラリを指定した場合はその...