るりまサーチ (Ruby 2.3.0)

最速Rubyリファレンスマニュアル検索!
16件ヒット [1-16件を表示] (0.120秒)

別のキーワード

  1. rubygems gem
  2. rubygems/gem_openssl ssl_available?
  3. rubygems/gem_openssl ensure_ssl_available
  4. gem set_home
  5. gem directories

検索結果

Gem::Requirement#satisfied_by?(version) -> bool (63022.0)

引数 version が自身に含まれる全ての必要条件を満たす場合に真を返します。 そうでなければ偽を返します。

引数 version が自身に含まれる全ての必要条件を満たす場合に真を返します。
そうでなければ偽を返します。

@param version Gem::Version のインスタンスを指定します。

@see Gem::Requirement#satisfy?

Gem::Requirement#satisfy?(op, version, required_version) -> bool (63022.0)

version op required_version を満たす場合に真を返します。 そうでなければ偽を返します。

version op required_version を満たす場合に真を返します。
そうでなければ偽を返します。

@param op 比較演算子 (<, <=, =, =>, >, !=, ~>) を文字列で指定します。

@param version 外部から与えられるバージョンを Gem::Version のインスタンスで指定します。

@param required_version 満たすべき条件を示すバージョンを指定します。

@see Gem::Requirement#satisfied_by?

Gem::Requirement#normalize -> nil (63004.0)

self を正規化します。

self を正規化します。

Gem::Requirement#parse(obj) -> Array (63004.0)

バージョンの必要上件をパースして比較演算子とバージョンを要素とする二要素の配列を返します。

バージョンの必要上件をパースして比較演算子とバージョンを要素とする二要素の配列を返します。

@param obj 必要上件を表す文字列または Gem::Version のインスタンスを指定します。

@return 比較演算子と Gem::Version のインスタンスを要素とする二要素の配列を返します。

@raise ArgumentError obj に不正なオブジェクトを指定すると発生します。

Gem::SourceIndex#find_name(gem_name, version_requirement = Gem::Requirement.default) -> Gem::Specification (325.0)

短い名前で正確にマッチする Gem を返します。

短い名前で正確にマッチする Gem を返します。

@param gem_name Gem の名前を指定します。

@param version_requirement

@see Gem::Requirement

絞り込み条件を変える

Gem::Dependency#version_requirements -> Gem::Requirement (307.0)

依存しているバージョンを返します。

依存しているバージョンを返します。

Gem::DependencyInstaller#find_spec_by_name_and_version(gem_name, version = Gem::Requirement.default) -> Array (307.0)

与えられた Gem の名前とバージョンに関する条件にマッチする Gem::Specification と それの存在する URI を含む配列を返します。

与えられた Gem の名前とバージョンに関する条件にマッチする Gem::Specification と
それの存在する URI を含む配列を返します。

@param gem_name Gem の名前を指定します。

@param version Gem が満たすバージョンに関する条件を指定します。

Gem::DependencyInstaller#install(dep_or_name, version = Gem::Requirement.default) -> Array (307.0)

指定された Gem とその依存する Gem を全てインストールします。

指定された Gem とその依存する Gem を全てインストールします。

@param dep_or_name Gem の名前か Gem::Dependency のインスタンスを指定します。

@param version バージョンに関する条件を指定します。

@return このメソッドでインストールした Gem のリストを返します。

Gem::Specification#required_ruby_version -> Gem::Requirement (307.0)

この Gem パッケージを動作させるのに必要な Ruby のバージョンを返します。

この Gem パッケージを動作させるのに必要な Ruby のバージョンを返します。

Gem::Specification#required_rubygems_version -> Gem::Requirement (307.0)

この Gem パッケージを動作させるのに必要な RubyGems のバージョンを返します。

この Gem パッケージを動作させるのに必要な RubyGems のバージョンを返します。

絞り込み条件を変える

Gem::LoadError#version_requirement=(version_requirement) (40.0)

ロードに失敗した Gem の必要条件をセットします。

ロードに失敗した Gem の必要条件をセットします。

@param version_requirement Gem::Requirement のインスタンスをセットします。

@see Gem::Requirement, Gem::Dependency#version_requirements

Gem::Specification#required_ruby_version=(requirement) (40.0)

この Gem パッケージを動作させるのに必要な Ruby のバージョンをセットします。

この Gem パッケージを動作させるのに必要な Ruby のバージョンをセットします。

@param requirement Gem::Requirement.create が受け付ける形式のオブジェクトを指定します。

@see Gem::Requirement

Gem::Specification#required_rubygems_version=(requirement) (40.0)

この Gem パッケージを動作させるのに必要な RubyGems のバージョンをセットします。

この Gem パッケージを動作させるのに必要な RubyGems のバージョンをセットします。

@param requirement Gem::Requirement.create が受け付ける形式のオブジェクトを指定します。

@see Gem::Requirement

Gem::Dependency#version_requirements=(version_requirements) (22.0)

依存しているバージョンを設定します。

依存しているバージョンを設定します。

@param version_requirements Gem::Requirement のインスタンスを指定します。

Gem::LoadError#version_requirement -> Get::Requirement (22.0)

ロードに失敗した Gem の必要条件を返します。

ロードに失敗した Gem の必要条件を返します。

@see Gem::Requirement, Gem::Dependency#version_requirements

絞り込み条件を変える

Gem::Version#version=(version) (22.0)

self のバージョン情報を書き換えます。

self のバージョン情報を書き換えます。


@todo Gem::Requirement に書く