るりまサーチ (Ruby 2.1.0)

最速Rubyリファレンスマニュアル検索!
3件ヒット [1-3件を表示] (0.018秒)
トップページ > モジュール:Kernel[x] > クエリ:gem[x] > バージョン:2.1.0[x]

別のキーワード

  1. rubygems gem
  2. rubygems/gem_openssl ssl_available?
  3. rubygems/gem_openssl ensure_ssl_available
  4. gem dir
  5. gem md5

ライブラリ

キーワード

検索結果

Kernel#gem(gem_name, *version_requirements) -> bool (18388.0)

$LOAD_PATH に Ruby Gem を追加します。

$LOAD_PATH に Ruby Gem を追加します。

指定された Gem をロードする前にその Gem が必要とする Gem をロードします。
バージョン情報を省略した場合は、最も高いバージョンの Gem をロードします。
指定された Gem やその Gem が必要とする Gem が見つからなかった場合は
Gem::LoadError が発生します。

バージョンの指定方法に関しては Gem::Version を参照してください。

rubygems ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前に実行されます。

...

Kernel#require(path) -> bool (30.0)

RubyGems を require すると、Kernel#require が Gem を 要求されたときにロードするように置き換えます。

...RubyGems を require すると、Kernel#require が Gem を
要求されたときにロードするように置き換えます。

再定義された Kernel#require を呼び出すと以下の事を行います。
Ruby のロードパスに存在するライブラリを指定した場合はその...

Kernel#multitask(args) { ... } -> Rake::MultiTask (8.0)

事前タスクを並列実行するタスクを定義します。

事前タスクを並列実行するタスクを定義します。

与えられた事前タスクを実行する順序は不定です。

例:
multitask :deploy => [:deploy_gem, :deploy_rdoc]