るりまサーチ

最速Rubyリファレンスマニュアル検索!
14件ヒット [1-14件を表示] (0.014秒)

別のキーワード

  1. kernel require
  2. getoptlong require_order
  3. irb/ext/use-loader irb_require
  4. rubygems/custom_require require
  5. require execute

検索結果

Kernel#require(path) -> bool (18141.0)

RubyGems を require すると、Kernel#require が Gem を 要求されたときにロードするように置き換えます。

...
RubyGems
require すると、Kernel#require が Gem を
要求されたときにロードするように置き換えます。

再定義された Kernel#require を呼び出すと以下の事を行います。
Ruby のロードパスに存在するライブラリを指定した場合はその...

Kernel#gem(gem_name, *version_requirements) -> bool (109.0)

$LOAD_PATH に Ruby Gem を追加します。

...ジョンの指定方法に関しては Gem::Version を参照してください。

rubygems
ライブラリがライブラリバージョンの衝突を検出しない限り、
gem メソッドは全ての require メソッドよりも前に実行されます。

=== 環境変数 GEM_SKIP

特定...
...de.rb

@param gem Gem の名前の文字列か、Gem の依存関係を Gem::Dependency のインスタンスで指定します。

@param version_requirements 必要とする gem のバージョンを指定します。

@return Gem がロードできた場合は true を返します。ロードで...